Installer LSI MegaRAID Storage Manager sur Ubuntu

lsi megaraid 84016E

J’ai récemment acheté une carte LSI MegaRaid 84016E pour remplacer mon expander Chenbro qui a pris feu (j’avais connecté le molex dans le mauvais sens :-().

Cette carte SAS / Raid dispose de 16 ports et je me suis dis qu’il serait sympa d’installer LSI MegaRaid Storage Manager sur Ubuntu afin de gérer mes différents RAID et disques virtuels.

Voici la procédure à suivre pour installer LSI MegaRaid Storage Manager sur votre Ubuntu (j’utilise une version 64Bits):

echo "deb http://hwraid.le-vert.net/debian squeeze main" >> /etc/apt/sources.list
apt-get update
apt-get -y --force-yes install megacli megactl libc6-i386 lib32gcc1 lib32z1 lib32stdc++6 ia32-libs
wget http://djlab.com/stuff/libstdc++5_3.3.6-21ubuntu1_amd64.deb
dpkg -i libstdc++5_3.3.6-21ubuntu1_amd64.deb
wget http://djlab.com/stuff/libstdc++5_3.3.6-21ubuntu1_i386.deb
dpkg-deb -x libstdc++5_3.3.6-21ubuntu1_i386.deb lib32stdc++5
cp ./lib32stdc++5/usr/lib/libstdc++.so.5.0.7 /usr/lib32
ln -s /usr/lib32/libstdc++.so.5.0.7 /usr/lib32/libstdc++.so.5
wget http://djlab.com/stuff/libxerces-c28_2.8.0+deb1-2build1_i386.deb
dpkg-deb -x libxerces-c28_2.8.0+deb1-2build1_i386.deb lib32xerces-c28
mkdir -p /opt/lsi/Apache/
cp ./lib32xerces-c28/usr/lib/libxerces-c.so.28.0 /opt/lsi/Apache/
ln -s /opt/lsi/Apache/libxerces-c.so.28.0 /opt/lsi/Apache/libxerces-c.so.28
ln -s /opt/lsi/Apache/libxerces-c.so.28 /usr/lib/libxerces-c.so.28
ldconfig
 
apt-get install libstdc++5
wget https://djlab.com/stuff/megaraid-storage-manager_8.10-04_amd64.deb
dpkg -i megaraid-storage-manager_8.10-04_amd64.deb
 
wget http://djlab.com/stuff/getlibs-all.deb
dpkg -i getlibs-all.deb
getlibs -y -l libxerces-c.so.28 libicuuc.so.42
ldconfig
 
## Launch GUI (make sure X11 forwarding is enabled on SSH session):
## /usr/local/MegaRAID\ Storage\ Manager/startupui.sh

 

2 Responses to Installer LSI MegaRAID Storage Manager sur Ubuntu

  1. Pims says:

    Hi, i use your methode that work perfectly except when i reboot i lost my deskot

    To prevent this we should use Libstdc++5.3.3.6-21 and not de 20 (apt-get install libstdc++5) 😉

    thanks for the tuto

Leave a Reply

Your email address will not be published. Required fields are marked *